Previous Thread
Next Thread
Print Thread
Rate This Thread
Hop To
#3802279 - 06/27/13 07:48 PM Saitek driver problem  
Joined: Aug 2006
Posts: 157
BigDuke66 Offline
BigDuke66  Offline

Joined: Aug 2006
Posts: 157
First anyone a clue how I can get onto the Saitek forum? Disabling new user registration is very helpful...

My problem is that I tried to use the latest Saitek driver(Saitek_X52Pro_Flight_Controller_7_0_27_13_x64_Drivers.exe) but that installation simply freezes after a while and #%&*$# the system so hard that I have to use a rest point or else I can't get the system up again.
I also tried the old drivers(Saitek_X52Pro_Flight_Controller_SD6_64.exe) but here it is the same with the exception that this driver seems to install a bit differently and gets the first part over without problem, than it seem to install something about directoutput and that is where it hangs after a while.

I already tried this to clean the system:
1. Unplug your device from the computer

2. Uninstall the drivers

3. Uninstall the SST programming software

4. Delete the Saitek folders from the following paths :
C:\Program Files

5. Delete Saitek registry entries:

-Press and hold the Windows key on your keyboard and then press the letter R. This will open the Run box. Type regedit and then click ok.
The Registry Editor will have a list of folders on the left hand side. Go down into the following folders in order by clicking the + next to the folder name.

+Media Properties
+Private Properties
+Direct Input

Delete any folder inside the Direct Input folder that begins VID_06A3.

6. Reboot

7. Install the latest drivers and DO NOT PLUG IN YOUR X52 until the install program ASKS you to or you will have to redo this whole process.
But that didn't help.

I than manually tried to get rid of the Saitek crap by uninstalling the drivers manually, also trying to track down the registry entries and deleting them as well, but were I have problems is this file:
C:\Program Files\Saitek\DirectOutput\DirectOutputService.exe
I simply can't erase it and I get the feeling the this exe is the problem of the freezing installations.

Please guys I'm gong nuts, didn't have such silly driver problems since WindowsXP!
Any help cleaning my system of Saitek is very appreciated!

System config:
-Windows 7 SP1 64-Bit
-Intel Core i5 3570K
-ASRock Z77 Extreme4
-G.Skill F3-14900CL9D-8GBSR
-Gigabyte Radeon HD 7870 GHz Edition OC
-be quiet! Straight Power E9 CM 480W
-X-Fi Titanium PCI Express
-Seagate Barracuda 7200.14
-Pioneer BDR-207 DBK

Last edited by BigDuke66; 06/27/13 08:10 PM.

"Das Fliegen ist das Leben wert!"
Inline advert (2nd and 3rd post)

#3802427 - 06/28/13 05:22 AM Re: Saitek driver problem [Re: BigDuke66]  
Joined: Feb 2012
Posts: 153
Ttime Offline
Ttime  Offline

Joined: Feb 2012
Posts: 153
I don't have your board but see if you've got a bios setting for legacy usb. If so, I'd advise that you enable it. I've got a new board too and my x52 was having problems before I enabled that setting.

loc: Northern California
#3803745 - 07/01/13 11:38 PM Re: Saitek driver problem [Re: BigDuke66]  
Joined: Jul 2013
Posts: 1
Mr5by5 Offline
Junior Member
Mr5by5  Offline
Junior Member

Joined: Jul 2013
Posts: 1
Maine, USA
Saitek is pretty bad with customer support....actually I don't think it exists at all. I am a long time user of the X-36, and now that my beloved X-36 has finally given up the ghost, I picked up an X-65. I had a lot of problems software-wise with my new stick, and ended up finding the HIDDEN Saitek FTP driver site during an extended odyssey of pre-2010 forum posts of Saitek software issues. Well, I say "hidden", but it is really just unadvertised, not linked to, and not mentioned at all anywhere on the Saitek website. You might try taking a look there to see if they have a newer driver, or maybe a later version of your programming software.

Hope it helps, and PLEASE spread it around if you get the chance.

#3803760 - 07/02/13 12:27 AM Re: Saitek driver problem [Re: BigDuke66]  
Joined: Apr 2011
Posts: 67
soarfeat Offline
Junior Member
soarfeat  Offline
Junior Member

Joined: Apr 2011
Posts: 67
Hey BigDuke,
If you are still trying to clear all the stuff left behind after uninstalling the Saitek drivers try this utility from Logitech called ClrCalib ( Clear Calibration Utility ). Go to this link and scroll down to the Clear Calibration Utility --- read the readme and hopefully you should be good to go--it is a very simple tool that works great.
Clear Calibration Utility from Logitech

#3898234 - 01/19/14 10:05 PM Re: Saitek driver problem [Re: BigDuke66]  
Joined: Oct 2006
Posts: 20
Snacko Offline
Junior Member
Snacko  Offline
Junior Member

Joined: Oct 2006
Posts: 20
Columbus, Ohio USA
Just to help document Saitek x52 Pro problems and fixes, here's mine. My MFD would not work right...

I tried the new drivers twice now and hated them. My MFD would act strange (flashing; displaying wrong info) sometimes, and other times work fine for a while. I uninstalled the drivers and installed my old ones drivers and software. My old drivers had worked great on this same system for about 5 years now. (if it ain't broke, don't "update")

I would:
Unplug the x52 Pro
Uninstall the drivers and software
Delete the Saitek folders in Program Files & Windows/Temp
Delete registry entries
Install new drivers and plug in x52 when told.

I have done this about 5 times today. None of it helped. When I would download a profile, my x52 Pro MFD would not display the profile name. When I pressed a button it would not display the programmed button's name.

While looking at my X52 Device Drivers I noticed that most of them said they were version!!! How can that be if I just installed my old and drivers and software??? Then I noticed on the .exe Properties Description it said "Saitek SST (SD6)64bit Software webinstall". Web Install??? I've had this file for about 4 years!

So, I guessed it might be using the internet and downloading 'other' versions of drivers instead of installing the versions it said. So I unplugged my network cable and redid the steps above once again... That fixed it. My MFD suddenly started working fine. I plugged my network cable back in, and checked the Driver versions. Now some of them say or they just say Unknown instead of the newer version!

#4011929 - 09/19/14 06:55 PM Re: Saitek driver problem [Re: BigDuke66]  
Joined: Aug 2006
Posts: 157
BigDuke66 Offline
BigDuke66  Offline

Joined: Aug 2006
Posts: 157
Not sure why this dropped of my radar, anyhow what really helped was to plug the Saitek stuff into an USB2 port NOT USB3.
With USB2 everything runs fine.

"Das Fliegen ist das Leben wert!"
#4161213 - 08/26/15 12:58 AM Re: Saitek driver problem [Re: BigDuke66]  
Joined: Jun 2010
Posts: 1
EagleEye Offline
Junior Member
EagleEye  Offline
Junior Member

Joined: Jun 2010
Posts: 1
In windows 10 you can go to the Device Manager
Under Programmable Support you will find several items
Check their properties out under the properties tab
Delete those that say they are MadCatz
Now reboot your computer
Be sure you have also deleted any MadCatz folder in the temp file and used uninstall programs to delete anything Saitek and empty your recycle bin.

Before you download and install a new driver unplug any Saitek item from the system
Download the driver first before using the installer
Good Luck and you may have to wait for new Windows 10 drivers to get everything working right

Moderated by  RacerGT 

Quick Search
Recent Articles
Support SimHQ

If you shop on Amazon use this Amazon link to support SimHQ

Recent Topics
Kobe Bryant dies in helicopter crash
by Chaz. 01/26/20 07:59 PM
Walmart down huge. Hack?
by TerribleTwo. 01/26/20 04:42 PM
All Half-Life games free on Steam right now
by Coot. 01/26/20 04:28 AM
Australia Day Heroes
by Mad Max. 01/26/20 01:22 AM
Cousins might have prevented the First World War
by oldgrognard. 01/23/20 11:06 PM
RIP US Volunteers
by Mad Max. 01/23/20 09:49 PM
Thoughts to live by....
by Bill_Grant. 01/23/20 05:13 PM
Deadly Animals ... Roosters
by Haggart. 01/23/20 04:18 AM
Beware of falling iguanas!
by CyBerkut. 01/22/20 03:46 PM
Copyright 1997-2016, SimHQ Inc. All Rights Reserved.

Powered by UBB.threads™ PHP Forum Software 7.6.0