Previous Thread
Next Thread
Print Thread
Rate This Thread
Hop To
#4508405 - 02/25/20 02:45 PM JoySetup MMjoy2  
Joined: Feb 2017
Posts: 2
Saville Offline
Junior Member
Saville  Offline
Junior Member

Joined: Feb 2017
Posts: 2
Brazil-Rio de Janeiro
Hello everyone !!
Please I need help !!
I have HOTAS Cougar, I'm using Pro Micro on it, I don't use the original HOTAS Cougar PCB !!
How to configure JoySetup for HOTAS Cougar, I will post links from my Channel on YouTube, trying to configure Joystick HOTAS Cougar, would any of you have any tutorial on how to configure HOTAS Cougar on JoySetup?
Links below:
https://www.youtube.com/watch?v=6AdgRWPkons&feature=em-lsp
https://www.youtube.com/watch?v=jsrDZmXbfBU
https://i.postimg.cc/FzmDC3ww/IMG-0597.jpg
https://i.postimg.cc/Qt9wnWvc/IMG-0610.jpg
https://i.postimg.cc/sX5TJwHp/IMG-0596.jpg
https://i.postimg.cc/SKqKbP1b/IMG-0587.jpg

Thanks for any help !!!

Last edited by Saville; 02/25/20 03:53 PM. Reason: added photos
Inline advert (2nd and 3rd post)

#4508451 - 02/25/20 07:43 PM Re: JoySetup MMjoy2 [Re: Saville]  
Joined: Nov 2001
Posts: 3,776
Sokol1 Offline
Senior Member
Sokol1  Offline
Senior Member

Joined: Nov 2001
Posts: 3,776
Internet
How Saville wired Cougar Shift Register and two TLE5011 in Arduino PRO Micro + MMjoy:

[Linked Image]

Y axis wire is not show, but use F4.

[Linked Image]

#4509154 - 03/02/20 01:15 PM Re: JoySetup MMjoy2 [Re: Saville]  
Joined: Nov 2016
Posts: 43
AIRWOLFMUTLEY Offline
Junior Member
AIRWOLFMUTLEY  Offline
Junior Member

Joined: Nov 2016
Posts: 43
Curitiba - Paran� - Brazil
Savile,

Aparentemente os seus eixos estão respondendo corretamente. Tente a opção de colocar saved with center como o Sokol já mencionou. E teste com os botões desconectados do arduino, para ter certeza de que o shift register não está interferindo no funcionamento dos eixos.

#4509175 - 03/02/20 02:25 PM Re: JoySetup MMjoy2 [Re: Saville]  
Joined: Nov 2001
Posts: 3,776
Sokol1 Offline
Senior Member
Sokol1  Offline
Senior Member

Joined: Nov 2001
Posts: 3,776
Internet
Airwolfmutley

He fix the Shift Register connections, his problem was a bad contact (and/or bad solder) in a splice of wires.

In my understanding, he is not doing the correct calibration of the axes.

Do you know if are any videos on how to do the calibration?

#4509189 - 03/02/20 03:45 PM Re: JoySetup MMjoy2 [Re: Sokol1]  
Joined: Nov 2016
Posts: 43
AIRWOLFMUTLEY Offline
Junior Member
AIRWOLFMUTLEY  Offline
Junior Member

Joined: Nov 2016
Posts: 43
Curitiba - Paran� - Brazil
Fala Sokol,

Não me recordo de nenhum vídeo assim. Mas não tem muito segredo mesmo, desde que as pcbs estejam funcionando e as respectivas conexões estejam ok; se estiverem falhando, ora vai parecer que funciona, ora para e daí dá problema. Se fizer tudo certo tem que funcionar.
É só definir os parâmetros, com saved with center, para garantir. É quase intuitivo.
O ideal seria ele testar e fazer funcionar primeiro só com as TLE's conectadas. Quando ele conseguir fazer isso dar certo, daí ele parte para conectar o shift register. Pelo vídeo que ele pôs no youtube os sensores estão dando leitura.
Outra coisa, talvez seja ideal ele tentar com outro número de VID/PID, tipo 0011.
Esta é a configuração atual do meu manche:
[Linked Image]

Last edited by AIRWOLFMUTLEY; 03/02/20 03:50 PM.

Moderated by  RacerGT 

Quick Search
Recent Articles
Support SimHQ

If you shop on Amazon use this Amazon link to support SimHQ
.
Social


Recent Topics
76 years ago today -- D-Day
by Sluggish Controls. 06/06/20 04:13 AM
Very educational F-22 video
by Zamzow. 06/05/20 11:35 PM
Justice for Maddie
by RossUK. 06/04/20 11:11 AM
Perhaps My Final Flight
by FishTaco. 06/04/20 02:59 AM
Blue Angel's will transition to the Rhino
by CyBerkut. 06/02/20 12:41 PM
The pancake chef...
by Mr_Blastman. 05/31/20 06:33 PM
DOSBox/MS-DOS6
by MarkG. 05/31/20 02:14 PM
Question for gun lovers
by Blade_RJ. 05/30/20 02:54 PM
Copyright 1997-2016, SimHQ Inc. All Rights Reserved.

Powered by UBB.threads™ PHP Forum Software 7.6.0