Previous Thread
Next Thread
Print Thread
Rate This Thread
Hop To
#3933378 - 04/02/14 12:24 PM Low framerate in fullscreen mode  
Joined: Mar 2014
Posts: 5
Echo7 Offline
Junior Member
Echo7  Offline
Junior Member

Joined: Mar 2014
Posts: 5
Hi all,
My system is an i5 4670k @ 4 G, 770 gtx, latest drivers, windows 8.1
Running EECH 1.15 on fullscreen mode I get a low framerate of 20-25 FPS. The low framrete is present even in the main menu (mouse movement and text animations). Switching to windowed mode in eech.ini resolves the problem (50-100 FPS). I installed according to the guide at EECH central: http://eechcentral.simhq.com/index.php?title=Installation_guide
I tried the following, which had no effect: lowest menu gfx settings @ 640*480, changing the FPS limiter in eech.in to 30-100, drivers: vsync on/off/adpative, power managment - "prefer maximum performance". I also tried 1.15.2 RC3 exe.
Any other suggestions? The window has borders which are distracting in flight.

I'm using the DS exe's as I don't have OpenAL - could this be an issue?

Thanks!

#3933415 - 04/02/14 02:32 PM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Dec 2012
Posts: 1,178
thealx Offline
Member
thealx  Offline
Member

Joined: Dec 2012
Posts: 1,178
is 32bit=1 in eech.ini?

#3933424 - 04/02/14 02:40 PM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Mar 2014
Posts: 5
Echo7 Offline
Junior Member
Echo7  Offline
Junior Member

Joined: Mar 2014
Posts: 5
yeap 32 bit is active.

edit: I also tried the following from here, still no good: http://eechcentral.simhq.com/index.php?title=Troubleshooting_FAQ

Quote:
Q.png I have an nvidia GFX card, and get slow frame rates
A.png Try the following settings in nvidia control panel, it works for some:

Anisotropic filtering 16x
Antialiasing 8x
Tripple Buffer = ON
Vert Sync = Force ON



edit 2 - found this post by another user with a similar problem. For him the FPS is fine when exporting to a second monitor. I'm using one monitor so I can't test it.
http://simhq.com/forum/ubbthreads.php/topics/3888880/Re_Mouse_Jitteriness#Post3888880

Last edited by Echo7; 04/02/14 03:31 PM.
#3933577 - 04/02/14 07:07 PM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Dec 2011
Posts: 172
Doctor_Wibble Offline
Member
Doctor_Wibble  Offline
Member

Joined: Dec 2011
Posts: 172
Is it maybe doing something weird like going into tv-output mode, e.g. triggered only when going into fullscreen?
I had one card (or maybe it was a laptop, can't remember) that kept changing screen mode if I hadn't explicitly disabled it from trying to auto-detect a tv even when there was no tv connected.

Or the screen is detecting the change and is signalling back a tv-sync refresh rate?

My guesswork is now reaching its limit, anything more is going to involve an escaped radioactive hamster chewing the wire in a desperate attempt to stop the toaster's fiendish plan for world domination.

#3933618 - 04/02/14 09:11 PM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Mar 2014
Posts: 5
Echo7 Offline
Junior Member
Echo7  Offline
Junior Member

Joined: Mar 2014
Posts: 5
I checked and the multi monitor options in windows and in the nvidia drivers are disabled. I'm also running with the intel graphics chip disabled in the bios.
:/

#3933801 - 04/03/14 09:36 AM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Dec 2011
Posts: 172
Doctor_Wibble Offline
Member
Doctor_Wibble  Offline
Member

Joined: Dec 2011
Posts: 172
Have you tried using older drivers?
I'm using an old set at the moment because I have several older games that work really badly under newer drivers, at least partly I think due to the DirectX version they expect.

Not sure of the exact technical reason but HL2 and AVP would hit a crawl if there was any fire visible plus other games had lots of texture flashing so I'm currently using the forceware 163.75 drivers (older card, on XP) though for yours maybe you need something a bit more recent than that...

#3933825 - 04/03/14 11:44 AM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Dec 2010
Posts: 1,423
messyhead Offline
messyhead  Offline

Member

Joined: Dec 2010
Posts: 1,423
I got this as well, but I managed to fix.


Let me think how I did it.......it was some setting in eech.ini.....

Is there a vsync setting in eech.ini?

#3933828 - 04/03/14 11:59 AM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Dec 2010
Posts: 1,423
messyhead Offline
messyhead  Offline

Member

Joined: Dec 2010
Posts: 1,423
This was how I fixed it for me, from the other thread you posted above...


http://simhq.com/forum/ubbthreads.php/topics/3857375/Re_Mouse_Jitteriness#Post3857375

#3933888 - 04/03/14 02:05 PM Re: Low framerate in fullscreen mode [Re: messyhead]  
Joined: Mar 2014
Posts: 5
Echo7 Offline
Junior Member
Echo7  Offline
Junior Member

Joined: Mar 2014
Posts: 5
Thanks for all the help guys. I still can't get it to work properly.

Originally Posted By: messyhead
This was how I fixed it for me, from the other thread you posted above...
http://simhq.com/forum/ubbthreads.php/topics/3857375/Re_Mouse_Jitteriness#Post3857375


32 bit is enabled in my eech.ini.

Originally Posted By: Doctor_Wibble
Have you tried using older drivers?
I'm using an old set at the moment because I have several older games that work really badly under newer drivers, at least partly I think due to the DirectX version they expect.

Not sure of the exact technical reason but HL2 and AVP would hit a crawl if there was any fire visible plus other games had lots of texture flashing so I'm currently using the forceware 163.75 drivers (older card, on XP) though for yours maybe you need something a bit more recent than that...


The 770 can only use drivers from the last year or so, and drivers before the latest ones (335.23) have issues in BMS so they are not an option for me.
The low framerate is universal (even in the main menu) and not tied to an effect or scene.

edit: I also tried compatibility mode from XP SP3 to W7.

Last edited by Echo7; 04/03/14 02:16 PM.
#3933956 - 04/03/14 04:17 PM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Dec 2011
Posts: 172
Doctor_Wibble Offline
Member
Doctor_Wibble  Offline
Member

Joined: Dec 2011
Posts: 172
Originally Posted By: Echo7
... The low framerate is universal (even in the main menu) and not tied to an effect or scene. ...

OK, next up, try taking the framerate mfr value up to a much higher value, e.g. 360 - something with the way it's used/calculated make it less obvious - I got significant improvements every time I increased it and at mfr=150 my antique can go up to around 50fps and only goes below 20fps when there's lots of buildings visible.

Or your cat is leaning on the space bar again. Waiting for the hamster.

#3933976 - 04/03/14 04:59 PM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Dec 2012
Posts: 1,178
thealx Offline
Member
thealx  Offline
Member

Joined: Dec 2012
Posts: 1,178
you can try to run game with your HD4600 video. but you should be a true eech fan to switch wire and bios settings every time you want to play it))

#4451302 - 12/01/18 11:34 AM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Nov 2018
Posts: 60
PatrykW Offline
Junior Member
PatrykW  Offline
Junior Member

Joined: Nov 2018
Posts: 60
Gillingham
Sorry to dig this zombie post out but has anyone resolved this? I have done a clean install of EECH 1.16 including the fix but my framerate is not that greate? Is it just the nature of the beast? The max I can get is around 60 but even after changing the eech.ini i cant get above that. Apart from that when the situation on the field gets a bit hairy my fps drops to something like 20-30?

PC Specs:

Win 10 Pro 64
AMD A8-6600K
16GB DDR3
GTX 770 2GB

#4452221 - 12/07/18 07:57 AM Re: Low framerate in fullscreen mode [Re: PatrykW]  
Joined: Dec 2010
Posts: 1,423
messyhead Offline
messyhead  Offline

Member

Joined: Dec 2010
Posts: 1,423
Originally Posted by PatrykW
Sorry to dig this zombie post out but has anyone resolved this? I have done a clean install of EECH 1.16 including the fix but my framerate is not that greate? Is it just the nature of the beast? The max I can get is around 60 but even after changing the eech.ini i cant get above that. Apart from that when the situation on the field gets a bit hairy my fps drops to something like 20-30?

PC Specs:

Win 10 Pro 64
AMD A8-6600K
16GB DDR3
GTX 770 2GB



Does this only happen in fullscreen mode?

What resolution are you running it in?

I think I sometimes get framreate drops, but my laptop is 10+ years old. For the most part it runs fine at 30-50fps for me

#4452229 - 12/07/18 10:32 AM Re: Low framerate in fullscreen mode [Re: messyhead]  
Joined: Nov 2018
Posts: 60
PatrykW Offline
Junior Member
PatrykW  Offline
Junior Member

Joined: Nov 2018
Posts: 60
Gillingham
Hi there

Same framerate on full screen and window mode, 1920x1080 but since this post I have moved to Win7 and did some tweaks and the framerate is ok now (I think) - goes from 60 down to 28-30. Got a feeling that a lot of dynamic stuff is happening in the background and the original code was not really optimized to use modern cpu's but it's still ok, I'm happy for now smile

#4452392 - 12/08/18 01:58 PM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Dec 2010
Posts: 1,423
messyhead Offline
messyhead  Offline

Member

Joined: Dec 2010
Posts: 1,423
I run it on Windows 10 without any problems. I did think that maybe it needs to have an older version of DirectX installed as well.

#4456884 - 01/11/19 10:43 AM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Jan 2019
Posts: 10
Gruutch Offline
Junior Member
Gruutch  Offline
Junior Member

Joined: Jan 2019
Posts: 10
Hi Folks,

I run EEHC 1.16 with several mods with Win10, i5 and GF1050 in 2540x1440 resolution with 60 fps without problems.
I have found that the entry notnl in the ini file has a massive impact on the frame rate (at least for me). Had to disable the TNL support for proper framerate.


Originally Posted by thealx
is 32bit=1 in eech.ini?

I do not have such entry in the ini file. Important? Where to put?

P.S. I'm playing several flight-sims since many years (my all time favourite is jane's Longbow 2). Meanwhile I'm quite experienced ;-) . But due family reasons hadn't much time. Now the kids are growing up and i hope to finde more time to play (and answer questions in forum's :-) ).

#4457177 - 01/13/19 09:03 PM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Nov 2018
Posts: 60
PatrykW Offline
Junior Member
PatrykW  Offline
Junior Member

Joined: Nov 2018
Posts: 60
Gillingham
Gruutch - as far as I remember the above entry refers to version 1.15 and I have not seen it on eech.ini for 1.16. I will definitely try the TNL support option as I am suffering really low frame rates (but I only have an AMD A8-6600k which is a bit dated)

#4457264 - 01/14/19 03:39 PM Re: Low framerate in fullscreen mode [Re: Echo7]  
Joined: Jan 2019
Posts: 10
Gruutch Offline
Junior Member
Gruutch  Offline
Junior Member

Joined: Jan 2019
Posts: 10
Ah ok, so it is not needed for my 1.16. Thanks.


Moderated by  messyhead, RacerGT 

Quick Search
Recent Articles
Support SimHQ

If you shop on Amazon use this Amazon link to support SimHQ
.
Social


Recent Topics
Why Looney Tunes is great for history buffs
by PanzerMeyer. 10/20/19 11:05 PM
IJN Kaga found.
by NH2112. 10/19/19 10:32 PM
Grouch (Joker Parady)
by Arthonon. 10/19/19 02:19 PM
Nike vs B-17
by KraziKanuK. 10/18/19 08:30 PM
Grouch
by Chaz. 10/18/19 01:49 PM
How to pi$$ off Londoners...
by Chucky. 10/17/19 12:16 PM
Video game map size comparison
by DM. 10/17/19 09:45 AM
Happy Thanksgiving
by No105_Archie. 10/13/19 05:15 PM
Happy Birthday US Navy
by oldgrognard. 10/13/19 04:31 PM
Copyright 1997-2016, SimHQ Inc. All Rights Reserved.

Powered by UBB.threads™ PHP Forum Software 7.6.0