I had a recent memory issue with the Ryzen 3 1200 build. One brand failed to be recognized by W10 -- only recognized 8GB of 16GB (although the hardware and a benchmark app said it was there). Tried "everything" -- fail. Finally, tried a different brand -- worked instantly and easily OC to 3200MHz with just a click in BIOS (the speed it was advertised to give). Wound up using this (got on sale -- sale only 6 more hours).

Memory that Worked as Advertised

Also, on memory, I found the 1600 and 1800 actually run measurably faster with memory clocked up to 2933MHz. Articles said that would happen -- those CPUs actually need fast memory to work their best (most AMD CPUs in the past didn't respond much to memory speed). Over 2933GHz makes no difference on my systems. Don't know if it applies to the 2600 and 2700 series because they are different (and faster) inside.


RX5700XT 50th Anniversary - 3 monitors = 24P (1200p) + 43"L (2160p) + 24P (1200p), AMD Ryzen 7 3800X, 32GB @3.2GHz, Gigabyte X570 AORUS Pro WIFI MB, (2x M.2 SSD on MB + SSD + 5x HD) = 25TB storage, Rosewill 1050W PSU, Rosewill Thor V2 Case, ASUS AC86U router, VKB Gladiator WW2 Stick, Pedals, Ripjaws KM780 RGB KB, AORUS Thunder M7 Mouse, W10 Pro