I saw some people with K-lite codec packs having problems with F4AF, and I had the same problem, uninstalling the code pack did solve the problem, but theres another solution.

So, I downloaded it again, to troubleshoot another problem related with movies and my Nero, I did solve, in return the F4AF problem.

So here is what you will do;

Copy the file name --> FalconAF.exe
Then click in Start-> all programs ->K-lite Codec Pack-> configuration-> ffdshow video decoder (the one with a red icon)

A window will open
Now, in the right side theres a bunch of options or menus. Select DirectShow Control Now the third option, it says Dont use ffdshow in:
Go to the end of the line, just after a ; paste FalconAF.exe at the end and close it with a ;
Mine looks like this
explorer.exe;FalconAF.exe;morrowind.exe;oblivion.exe;

Now, launch your F4AFand fly fly!!!

So, see if this will work for you, because with me is working wonders nowAnd since I suffered this problem before, Im not sure if anyone is still suffering it, or suffered itso I leave this little contribution to this nice community(PS: sorry if this a repeated topic) Of course there this other solution, shown at the Lead Pursuit website, but this one will only disable the Ffdshow(the responsible of crashes and problems) on F4AF...





This is the lead pursuit solution.

Quote:
You might have installed a 3rd party video codec packages. They can cause all possible issues and problems. For example, the K-Lite video codec package is known to cause problems with Falcon 4.0 Allied Force. If you have this installed, do the following:
Open Klite Codec pack > Configuration > Fddshow > Video decoder configuration and change the MP42 format entry to disabled by clicking on libavcodec.
As a result the standard MS codec will play the AVI movies and FDDshow is not used for this type. Falcon will run fine with movies then.