Forums » Miscellaneous » Naval Simulations » How To: Dangerous Waters with Windows 7 64-bit Active Topics You are not logged in. [Log In] [Register User]
Topic Options
Rate This Topic
Hop to:
#3419875 - 10/27/11 04:39 PM How To: Dangerous Waters with Windows 7 64-bit
Sauron Offline
Successor to Bill the Cat!
Hotshot

Registered: 11/09/09
Posts: 5872
Loc: Quantum Superstate
I've been trying to get Dangerous Waters to install and work right under Windows 7 64-bit Home Premium for a long time. I finally hit on the right combo.

This applies to the Strategy First edition, v1.04 from the disc, no need to patch. As for other editions, I don't know.

I'm running an AMD Phenom II 1099T 6-core with an ATI Radeon 5870 and 8 GB of DDR3 RAM in case anyone is wondering about my system.

Insert disc.

Right click on "setupDangerousWaters.exe".

Select "Properties" then go the "Compatibility" tab.

Select "Run this program in Compatibility Mode for: Windows XP (Service Pack 2)"

Put a tick in "Disable Visual Themes", "Disable Desktop Composition", and "Run this program as an administrator".

Click "Apply" and exit "Properties" dialog.

Double click the "setupDangerousWaters.exe". Follow onscreen commands to install. DO NOT install to "Program Files (X86)" folder. Create a folder on your main hard drive such as "Games", i.e. install to "C:\Games\Strategy First\Dangerous Waters" or something like that.

Go to your video card setup utility. Set antialiasing to "Supersample". If you do not, and you let it run in any form of "Multisample", you'll have graphics problems.

Alternatively, tick "Use application settings", but you won't have antialiasing.

And now for the CRITICAL STEP: YOU MUST RUN THE GAME FROM THE "LaunchDW.exe" executable the first time or you will have errors when you try to run the game! DO NOT launch the game with the desktop icon the first time! Instead, do this:

Go to the game's main directory. Locate the file "LaunchDW.exe". Right click it, go to "Properties", then put a tick mark in "Run this program in Compatibility Mode for: Windows XP (Service Pack 3). Now put a tick mark in "Run this program as an administrator". I know, it's not the same thing we used for the "setupDangerousWaters.exe" but don't blame me, I'm just reporting what worked.

Double click "LaunchDW.exe". Click "Play" on the dialog box that comes up. Put your name in the "New Player" box. Now click on "Options".

The game will minimize and the Speech Recognition setup dialog will come up. Don't close it, just ignore it for now. Go to your task bar and click on the Dangerous Waters icon to bring the minimized game back up on screen.

Set your options as you like. Exit the game. Kill the Speech Recognition dialog unless you want to set up speech recognition.

Now, edit the desktop icon. Right click it, go to "Properties", and make sure that "Target" is set to ""C:\Games\Strategy First\Dangerous Waters\dangerouswaters.exe" or wherever you installed the game.

Edit the "Start in:" box so it reads "C:\Games\Strategy First\Dangerous Waters". Click "Apply" and exit the "Properties" dialog.

Set "Compatibility" settings for desktop icon to "Run this program in "Run this program in Compatibility Mode for: Windows XP (Service Pack 2)". Put a tick in "Disable Visual Themes", "Disable Desktop Composition", and "Run this program as an administrator". Click "Apply" and exit "Properties" dialog.

Launch the game with the desktop icon. Go into options again and make sure all your options are set as you want. Make sure that your name is still in the "New Player" dialog and if not, enter it. When that is all done, exit the game.

Restart your machine and you should be good to go. You can hopefully now play Dangerous Waters from the desktop icon with no problems. It worked for me.

Now, if someone who knows what they're doing would make us a .dll with the Windows Application Compatibility Tool Kit for Windows 7 so that we could run the game at 1920x1080, life would be dang near perfect!

Cheers!

Rick... ahoy
_________________________
"We are extending ourselves in Space and Time not because of capitalism or socialism but in spite of them. The Right/Left Capitalist/Socialist establishments are psychologically unprepared for our emerging situation in Time and Space." - F. M. Esfandiary, Upwingers

Top
#3419991 - 10/27/11 07:10 PM Re: How To: Dangerous Waters with Windows 7 64-bit [Re: Sauron]
jaegermeister Offline
Member

Registered: 03/31/07
Posts: 532
Loc: Walking point
Hi Rick,
it sounds as though you've been on a roller coaster ride with DW.
I have the original Battlefront version of DW. The only thing that i do to my 4 different installed versions
is set the compatibility to win-xp3 and run as administrator.
I also apply compatibility settings for the (1st) first install which I then patch to 1.04.
I back-up the registry and copy the installed folder rename it apply mods and edit the registry.
The sound/speech pop-up you can ignore untill you're thru' playing the close it after you exit.
However, since I moved over to this i72600k Proc, I haven't had the speech popup request.

Jaeger

Top
Topic Options
Rate This Topic
Hop to:

Moderator:  EinsteinEP, RacerGT 
 
Quick Search
Recent Articles
Support SimHQ
.
Social


Recent Topics
Interested in Staying in the Swiss Alps in the Beautiful Town of Lauterbrunnen Paying No Rent For 1 Year ?
by Haggart
18 minutes 15 seconds ago
Civ: Beyond Earth @ a low price!
by - Ice
32 minutes 7 seconds ago
Doorkickers tactical help...
by Magnum
57 minutes 37 seconds ago
So...that looks like a design flaw...
by AggressorBLUE
Today at 10:02 AM
Does not support multi monitor/Triple Screen..
by mac495
Today at 09:35 AM
2014 Wings Over North Georgia Airshow
by CJBuff
Today at 09:34 AM
Cost of University in U.S. $10,000/semester; Germany = Free & for International Students
by Haggart
Today at 09:12 AM
Great to see so much SB lately...
by Magnum
Today at 08:26 AM
Absolutely great Uncharted: Drake's Fortune fan film
by semmern
Today at 06:40 AM
Can anybody proof the rumor on low cost russian version
by Zoltann
Today at 05:28 AM
 

Forum Use Agreement | Privacy Statement
Copyright 1997-2014, SimHQ Inc. All Rights Reserved.